Во время попытки установки VLC плеера, возникала ошибка установки, заблаговременно хотелось бы сказать, ранее VLC был установлен, но по причине ошибок обновления  системы и зависимых библиотек был удален, настал момент когда удалось выбрать время и разрешить вопрос "безошибочной" установки VLC.

Итак, во время установки возникали ошибки следующего вида:

yum install vlc
...
Error: Package: vlc-1.1.13-1.el6.rf.i686 (@rpmforge)
           Requires: libthreadutil.so.2
           Removing: libupnp-1.6.6-1.el6.rf.i686 (@rpmforge)
               libthreadutil.so.2
           Updated By: libupnp-1.6.13-1.el6.i686 (epel)
               Not found
Error: Package: vlc-1.1.13-1.el6.rf.i686 (@rpmforge)
           Requires: libebml.so.2
           Removing: libebml-1.0.0-1.el6.rf.i686 (@rpmforge)
               libebml.so.2
           Updated By: libebml-1.2.1-1.el6.i686 (epel)
               Not found

Решение

Удаление всех зависимых библиотек:

yum remove libebml libebml

Добавление исключений в файл epel.repo - /etc/yum.repos.d/epel.repo:

exclude=libupnp* libebml* libmodplug* libmatroska* libupnp*

Добавить комментарий


Защитный код
Обновить

Сейчас 167 гостей и ни одного зарегистрированного пользователя на сайте

Вверх
Вниз